[versions-maven-plugin ] Report only direct dependencies that are not the latest

classic Classic list List threaded Threaded
3 messages Options
Reply | Threaded
Open this post in threaded view
|

[versions-maven-plugin ] Report only direct dependencies that are not the latest

Farrukh Najmi

Dear Colleagues,

I am just starting to use versions-maven-plugin:

http://mojo.codehaus.org/versions-maven-plugin/dependency-updates-report-mojo.html

I have a fairly complex multi-module project with a complex dependency tree.

I am only interested in finding out which of my direct dependencies are
not the latest version.

Is there a way to do that? It does not appear so. Please confirm and let
me know if its OK to file an RFE for this.

Thank you.

--
Regards,
Farrukh Najmi

Web: http://www.wellfleetsoftware.com


---------------------------------------------------------------------
To unsubscribe from this list, please visit:

    http://xircles.codehaus.org/manage_email


Reply | Threaded
Open this post in threaded view
|

Re: [versions-maven-plugin ] Report only direct dependencies that are not the latest

Wayne Fay
> I am only interested in finding out which of my direct dependencies are not
> the latest version.
>
> Is there a way to do that? It does not appear so. Please confirm and let me
> know if its OK to file an RFE for this.

Is this not what you want?
http://mojo.codehaus.org/versions-maven-plugin/examples/display-dependency-updates.html

Wayne

---------------------------------------------------------------------
To unsubscribe from this list, please visit:

    http://xircles.codehaus.org/manage_email


Reply | Threaded
Open this post in threaded view
|

Re: [versions-maven-plugin ] Report only direct dependencies that are not the latest

Farrukh Najmi

I was aware of the display-dependency-updates goal but found that it was reporting on dependencies both direct and transitive.
I was wondering if there was an option to give only direct dependency report.

I do see that indircet dependencies are markes seprately and clearly as in the following:

[INFO] The following dependencies in Dependencies have newer versions:

This seems good enough for me for now.

Thanks Wayne!

On 08/13/2012 05:01 PM, Wayne Fay wrote:
I am only interested in finding out which of my direct dependencies are not
the latest version.

Is there a way to do that? It does not appear so. Please confirm and let me
know if its OK to file an RFE for this.
Is this not what you want?
http://mojo.codehaus.org/versions-maven-plugin/examples/display-dependency-updates.html



-- 
Regards,
Farrukh Najmi

Web: http://www.wellfleetsoftware.com