rpm-maven-plugin: failed to resolve artifact mapping

classic Classic list List threaded Threaded
6 messages Options
Reply | Threaded
Open this post in threaded view
|

rpm-maven-plugin: failed to resolve artifact mapping

Andrey Hitrin
Hi all!

We've a project that uses rpm-maven-plugin to build rpm packages. Today we've suddenly faced a situation that our working project rejects to build.

I've created the simplest example that demonstrates this failure. Please see attached files.

Steps I've used to reproduce problem:

1. Create basic maven project (even without tests) and setup rpm build with artifact mapping (pom.xml)
2. (Successfully) build project artifact with `mvn package` (mvn-3.0.3.package.log)
3. Try to build rpm flie with `mvn rpm:rpm`, but failed (mvn-3.0.3.rpm.log and 3.0.5.rpm2.1.log)

I suspect that problem is not in the rpm-maven-plugin itself, but in some other plugin that is used to resolve project artifact. I've tried different versions of rpm-maven-plugin and different maven versions, and with the same result. The last friday everything worked ok.

Which plugin breaks the build? I hope you could help us in this situation.

--
Andrey Hitrin


---------------------------------------------------------------------
To unsubscribe from this list, please visit:

    http://xircles.codehaus.org/manage_email

pom.xml (2K) Download Attachment
mvn-3.0.3.package.log (83K) Download Attachment
mvn-3.0.3.rpm.log (32K) Download Attachment
mvn-3.0.5.rpm2.1.log (33K) Download Attachment
Reply | Threaded
Open this post in threaded view
|

Re: rpm-maven-plugin: failed to resolve artifact mapping

Anders Hammar
A quick guess is that you need to execute
mvn install
first ot get the artifact installed into the local repo. Then you can execute
mvn rpm:rpm

DOn't understand why you want to execute rpm:rpm separately though...

/Anders


On Mon, Mar 4, 2013 at 5:44 PM, Андрей Хитрин <[hidden email]> wrote:
Hi all!

We've a project that uses rpm-maven-plugin to build rpm packages. Today we've suddenly faced a situation that our working project rejects to build.

I've created the simplest example that demonstrates this failure. Please see attached files.

Steps I've used to reproduce problem:

1. Create basic maven project (even without tests) and setup rpm build with artifact mapping (pom.xml)
2. (Successfully) build project artifact with `mvn package` (mvn-3.0.3.package.log)
3. Try to build rpm flie with `mvn rpm:rpm`, but failed (mvn-3.0.3.rpm.log and 3.0.5.rpm2.1.log)

I suspect that problem is not in the rpm-maven-plugin itself, but in some other plugin that is used to resolve project artifact. I've tried different versions of rpm-maven-plugin and different maven versions, and with the same result. The last friday everything worked ok.

Which plugin breaks the build? I hope you could help us in this situation.

--
Andrey Hitrin


---------------------------------------------------------------------
To unsubscribe from this list, please visit:

    http://xircles.codehaus.org/manage_email


Reply | Threaded
Open this post in threaded view
|

Re: rpm-maven-plugin: failed to resolve artifact mapping

Andrey Hitrin
A quick guess is that you need to execute
> mvn install

My bad! This definitely helps. Sorry for panic :(

DOn't understand why you want to execute rpm:rpm separately though...

Just did it "for easier log reading", nothing more.


2013/3/4 Anders Hammar <[hidden email]>
A quick guess is that you need to execute
mvn install
first ot get the artifact installed into the local repo. Then you can execute
mvn rpm:rpm

DOn't understand why you want to execute rpm:rpm separately though...

/Anders


On Mon, Mar 4, 2013 at 5:44 PM, Андрей Хитрин <[hidden email]> wrote:
Hi all!

We've a project that uses rpm-maven-plugin to build rpm packages. Today we've suddenly faced a situation that our working project rejects to build.

I've created the simplest example that demonstrates this failure. Please see attached files.

Steps I've used to reproduce problem:

1. Create basic maven project (even without tests) and setup rpm build with artifact mapping (pom.xml)
2. (Successfully) build project artifact with `mvn package` (mvn-3.0.3.package.log)
3. Try to build rpm flie with `mvn rpm:rpm`, but failed (mvn-3.0.3.rpm.log and 3.0.5.rpm2.1.log)

I suspect that problem is not in the rpm-maven-plugin itself, but in some other plugin that is used to resolve project artifact. I've tried different versions of rpm-maven-plugin and different maven versions, and with the same result. The last friday everything worked ok.

Which plugin breaks the build? I hope you could help us in this situation.

--
Andrey Hitrin


---------------------------------------------------------------------
To unsubscribe from this list, please visit:

    http://xircles.codehaus.org/manage_email





--
Andrey Hitrin
Reply | Threaded
Open this post in threaded view
|

Re: rpm-maven-plugin: failed to resolve artifact mapping

Andrey Hitrin
In reply to this post by Anders Hammar
Thank you for help!


2013/3/4 Anders Hammar <[hidden email]>
A quick guess is that you need to execute
mvn install
first ot get the artifact installed into the local repo. Then you can execute
mvn rpm:rpm

DOn't understand why you want to execute rpm:rpm separately though...

/Anders


On Mon, Mar 4, 2013 at 5:44 PM, Андрей Хитрин <[hidden email]> wrote:
Hi all!

We've a project that uses rpm-maven-plugin to build rpm packages. Today we've suddenly faced a situation that our working project rejects to build.

I've created the simplest example that demonstrates this failure. Please see attached files.

Steps I've used to reproduce problem:

1. Create basic maven project (even without tests) and setup rpm build with artifact mapping (pom.xml)
2. (Successfully) build project artifact with `mvn package` (mvn-3.0.3.package.log)
3. Try to build rpm flie with `mvn rpm:rpm`, but failed (mvn-3.0.3.rpm.log and 3.0.5.rpm2.1.log)

I suspect that problem is not in the rpm-maven-plugin itself, but in some other plugin that is used to resolve project artifact. I've tried different versions of rpm-maven-plugin and different maven versions, and with the same result. The last friday everything worked ok.

Which plugin breaks the build? I hope you could help us in this situation.

--
Andrey Hitrin


---------------------------------------------------------------------
To unsubscribe from this list, please visit:

    http://xircles.codehaus.org/manage_email





--
Andrey Hitrin
Reply | Threaded
Open this post in threaded view
|

Re: rpm-maven-plugin: failed to resolve artifact mapping

Andrey Hitrin
I think, it would be useful to provide more informative message in such case. Please take a look at the attached patch! It throws exception with (as I hope) helpful message when the artifact cannot be resolved. I think it's slightly better than NPE (which may be treated as failure in the plugin itself).


2013/3/4 Андрей Хитрин <[hidden email]>
Thank you for help!


2013/3/4 Anders Hammar <[hidden email]>
A quick guess is that you need to execute
mvn install
first ot get the artifact installed into the local repo. Then you can execute
mvn rpm:rpm

DOn't understand why you want to execute rpm:rpm separately though...

/Anders


On Mon, Mar 4, 2013 at 5:44 PM, Андрей Хитрин <[hidden email]> wrote:
Hi all!

We've a project that uses rpm-maven-plugin to build rpm packages. Today we've suddenly faced a situation that our working project rejects to build.

I've created the simplest example that demonstrates this failure. Please see attached files.

Steps I've used to reproduce problem:

1. Create basic maven project (even without tests) and setup rpm build with artifact mapping (pom.xml)
2. (Successfully) build project artifact with `mvn package` (mvn-3.0.3.package.log)
3. Try to build rpm flie with `mvn rpm:rpm`, but failed (mvn-3.0.3.rpm.log and 3.0.5.rpm2.1.log)

I suspect that problem is not in the rpm-maven-plugin itself, but in some other plugin that is used to resolve project artifact. I've tried different versions of rpm-maven-plugin and different maven versions, and with the same result. The last friday everything worked ok.

Which plugin breaks the build? I hope you could help us in this situation.

--
Andrey Hitrin


---------------------------------------------------------------------
To unsubscribe from this list, please visit:

    http://xircles.codehaus.org/manage_email





--
Andrey Hitrin



--
Андрей Хитрин


---------------------------------------------------------------------
To unsubscribe from this list, please visit:

    http://xircles.codehaus.org/manage_email

exception.patch (1K) Download Attachment
Reply | Threaded
Open this post in threaded view
|

Re: rpm-maven-plugin: failed to resolve artifact mapping

Anders Hammar
/Anders


On Tue, Mar 5, 2013 at 8:35 AM, Андрей Хитрин <[hidden email]> wrote:
I think, it would be useful to provide more informative message in such case. Please take a look at the attached patch! It throws exception with (as I hope) helpful message when the artifact cannot be resolved. I think it's slightly better than NPE (which may be treated as failure in the plugin itself).


2013/3/4 Андрей Хитрин <[hidden email]>
Thank you for help!


2013/3/4 Anders Hammar <[hidden email]>
A quick guess is that you need to execute
mvn install
first ot get the artifact installed into the local repo. Then you can execute
mvn rpm:rpm

DOn't understand why you want to execute rpm:rpm separately though...

/Anders


On Mon, Mar 4, 2013 at 5:44 PM, Андрей Хитрин <[hidden email]> wrote:
Hi all!

We've a project that uses rpm-maven-plugin to build rpm packages. Today we've suddenly faced a situation that our working project rejects to build.

I've created the simplest example that demonstrates this failure. Please see attached files.

Steps I've used to reproduce problem:

1. Create basic maven project (even without tests) and setup rpm build with artifact mapping (pom.xml)
2. (Successfully) build project artifact with `mvn package` (mvn-3.0.3.package.log)
3. Try to build rpm flie with `mvn rpm:rpm`, but failed (mvn-3.0.3.rpm.log and 3.0.5.rpm2.1.log)

I suspect that problem is not in the rpm-maven-plugin itself, but in some other plugin that is used to resolve project artifact. I've tried different versions of rpm-maven-plugin and different maven versions, and with the same result. The last friday everything worked ok.

Which plugin breaks the build? I hope you could help us in this situation.

--
Andrey Hitrin


---------------------------------------------------------------------
To unsubscribe from this list, please visit:

    http://xircles.codehaus.org/manage_email





--
Andrey Hitrin



--
Андрей Хитрин


---------------------------------------------------------------------
To unsubscribe from this list, please visit:

    http://xircles.codehaus.org/manage_email