jaxb2-maven-plugin fails to generate schemas

classic Classic list List threaded Threaded
2 messages Options
Reply | Threaded
Open this post in threaded view
|

jaxb2-maven-plugin fails to generate schemas

David Hoffer
We are using jaxb2-maven-plugin v1.6 on JDK8 and running the schemagen goal.  

We have a case now where it fails to generate any schema files and does not report the error.

[DEBUG] Using SchemaGen of JAXB Reference Implementation  version 2.2.8-b01
[DEBUG] Args for SchemaGenerator: [-d, C:\svn\JMS\trunk\satcat\satcat-domain\target\generated-resources\schemagen, -classpath, long list here]
null

Note that it just reports 'null' and then maven goes to the next plugin/etc.

What might be causing this error and how can I get the plugin to report what is causing this?

-Dave
Reply | Threaded
Open this post in threaded view
|

Re: jaxb2-maven-plugin fails to generate schemas

Anders Hammar
The JAXB-2 plugin v1.6 has some issues with JDK 1.8. I believe most of them have been fixed in v2.0, but that version hasn't been released yet.

/Anders

On Tue, Apr 14, 2015 at 11:22 PM, David Hoffer <[hidden email]> wrote:
We are using jaxb2-maven-plugin v1.6 on JDK8 and running the schemagen goal.  

We have a case now where it fails to generate any schema files and does not report the error.

[DEBUG] Using SchemaGen of JAXB Reference Implementation  version 2.2.8-b01
[DEBUG] Args for SchemaGenerator: [-d, C:\svn\JMS\trunk\satcat\satcat-domain\target\generated-resources\schemagen, -classpath, long list here]
null

Note that it just reports 'null' and then maven goes to the next plugin/etc.

What might be causing this error and how can I get the plugin to report what is causing this?

-Dave